Author Topic: Problem with bike  (Read 4806 times)

0 Members and 1 Guest are viewing this topic.

Offline Citydave

  • XR Member
  • **
  • Topic Author
  • Posts: 28
  • Bike: BMW S1000XR
  • Town: Buntingford
  • Country: gb
Problem with bike
on: July 01, 2015, 07:11:36 PM
Hi
Had my XR for 4 days, done 370 miles. Last night riding home from work the ABS light started to come on for no reason. A bit further into the journey everytime I went over a bump or through a hole in the road surface the lights went out and o lost all of the display on the dash. The bike cut out on six occasions and eventually the engine management light came. I managed to limp the bike home and BMW have now picked it up to have a look at it.

Any ideas anyone, I have the feeling it could be a major problem

Dave
City Dave

#1

Offline fasttrak

  • XR Pro
  • ***
  • Posts: 138
  • Bike: BMW S1000XR
  • Town: Morgan Hill
  • Country: us
Re: Problem with bike
Reply #1 on: July 01, 2015, 08:21:55 PM
two things come to mind, an engine ground wire was loose or a battery terminal was loose. Also, could be one of the main linbus connectors has a faulty pinout that needs to be fixed. Sounds electrical to me and not mechanical. Time will tell.

#2

Offline Citydave

  • XR Member
  • **
  • Topic Author
  • Posts: 28
  • Bike: BMW S1000XR
  • Town: Buntingford
  • Country: gb
Re: Problem with bike
Reply #2 on: July 01, 2015, 09:17:21 PM
Thanks Fasttrak, hopefully it is nothing serious, I love the bike. I will let you know

Cheers Dave
City Dave

#3

Offline grnmtvt

  • XR Pro
  • ***
  • Posts: 256
  • Bike: S1000XR
  • Town: Essex Junction
  • Country: us
Re: Problem with bike
Reply #3 on: July 07, 2015, 12:48:00 AM
Let us know what they find.  We'll all be waiting to hear.  I'll echo FastTrack and suggest they will get it diagnosed pretty quickly.
Many people ride.....but for a select group of people it's more than a ride....it's one of life's great passions.

#4

Offline Citydave

  • XR Member
  • **
  • Topic Author
  • Posts: 28
  • Bike: BMW S1000XR
  • Town: Buntingford
  • Country: gb
Re: Problem with bike
Reply #4 on: July 07, 2015, 03:31:46 PM
It turned out to be loose wiring leading to the ABS unit. Went in the following day and was repaired, rides like a dream
City Dave

#5

Offline grnmtvt

  • XR Pro
  • ***
  • Posts: 256
  • Bike: S1000XR
  • Town: Essex Junction
  • Country: us
Re: Problem with bike
Reply #5 on: July 08, 2015, 12:32:58 AM
Very glad to hear it!!   :046:
Many people ride.....but for a select group of people it's more than a ride....it's one of life's great passions.

#6

Offline fasttrak

  • XR Pro
  • ***
  • Posts: 138
  • Bike: BMW S1000XR
  • Town: Morgan Hill
  • Country: us
Re: Problem with bike
Reply #6 on: July 08, 2015, 01:14:43 AM
*Originally Posted by Citydave [+]
It turned out to be loose wiring leading to the ABS unit. Went in the following day and was repaired, rides like a dream

Pretty much what I figured and an easier repair for the shop to get you back on the road. Glad to hear no major disaster.

#7

Offline Citydave

  • XR Member
  • **
  • Topic Author
  • Posts: 28
  • Bike: BMW S1000XR
  • Town: Buntingford
  • Country: gb
Re: Problem with bike
Reply #7 on: July 08, 2015, 08:35:55 PM
Cheers
City Dave

 



dysfunctional