Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: OEM LED Turn Signals  (Read 2125 times)

0 Members and 1 Guest are viewing this topic.

Offline Mta1000XR

  • XR Member
  • **
  • Posts: 80
  • Country: us
  • Bike: 2018 S1000XR
  • Town: Connecticut
OEM LED Turn Signals
« on: February 25, 2018, 03:51:59 AM »
So I installed the same set of OEM LED turn signals that come standard on the European bikes onto my new XR that I had installed on my two previous S1000R's and I get the damn LAMPS! error. The flash rate is too fast. On the other two bikes there wasn't a problem, after I installed them on my previous R's the flash rate was fine and there was no error. I can't find anything about a flasher relay for the XR. I thought the ECU just new and it would work fine. Maybe they have to enable something in the ECU? Has any other US owner had this problem?
Ride That Thang!

Online smithy

  • XR Master
  • ****
  • Posts: 863
  • Country: au
  • Bike: 2017 S1000XR
  • Town: Sydney.
Re: OEM LED Turn Signals
« Reply #1 on: February 25, 2018, 06:08:42 AM »
What models were your previous bikes?? The later '17 & '18 models are Euro-4 and have can-bus wiring.

Smithy.
When I die, I want to go peacefully in my sleep like my Grandfather....not screaming like the passengers in his car..!

Offline LAMBO281

  • XR Pro
  • ***
  • Posts: 423
  • Country: gb
  • Live the dream and ride 247
  • Bike: S1000XR
  • Town: Berkshire UK
Re: OEM LED Turn Signals
« Reply #2 on: February 25, 2018, 07:24:00 AM »
Try a resister on each of the indicators, should slow it down and hopefully not cause an error on the system

Offline Mta1000XR

  • XR Member
  • **
  • Posts: 80
  • Country: us
  • Bike: 2018 S1000XR
  • Town: Connecticut
Re: OEM LED Turn Signals
« Reply #3 on: February 25, 2018, 10:43:35 AM »
*Originally Posted by smithy [+]
What models were your previous bikes?? The later '17 & '18 models are Euro-4 and have can-bus wiring.

Smithy.
'15 and '17
Ride That Thang!

Offline Mta1000XR

  • XR Member
  • **
  • Posts: 80
  • Country: us
  • Bike: 2018 S1000XR
  • Town: Connecticut
Re: OEM LED Turn Signals
« Reply #4 on: February 25, 2018, 10:46:13 AM »
*Originally Posted by LAMBO281 [+]
Try a resister on each of the indicators, should slow it down and hopefully not cause an error on the system

Damn I'd rather not take it all apart again for that lol. Especially when they were plug and play before. Does the gs911 have the capability to change that setting?
Ride That Thang!

Offline Winger

  • XR God
  • *****
  • Posts: 1663
  • Country: gb
  • Town: Birmingham
Re: OEM LED Turn Signals
« Reply #5 on: February 25, 2018, 02:12:21 PM »
It may do,i’ve Seen the same with the K12s/13’s when guys have fitted LED’s some have had to go to the dealers to get the relay reprogrammed others like me didn’t have problem.

Online SimonUK

  • XR Pro
  • ***
  • Posts: 295
  • Country: us
  • Bike: S1000XR,S1000R
  • Town: Upstate, SC
Re: OEM LED Turn Signals
« Reply #6 on: February 25, 2018, 02:14:35 PM »
*Originally Posted by Mta1000XR [+]
Damn I'd rather not take it all apart again for that lol. Especially when they were plug and play before. Does the gs911 have the capability to change that setting?

AFAIK the GS911 does not have that functionality, and this needs to be done at the dealers. I am interested in your resolution as I want to put LEDs on mine, have LED indicators on K1300S, R1200GS, S1000R without issues (or resistors).

Offline Mta1000XR

  • XR Member
  • **
  • Posts: 80
  • Country: us
  • Bike: 2018 S1000XR
  • Town: Connecticut
Re: OEM LED Turn Signals
« Reply #7 on: February 25, 2018, 02:20:20 PM »
Thanks, im glad someone knew before I dropped $400 on the gs911! I guess I'll have to talk to the dealer. This is pretty upsetting lol. I definitely don't wanna take it apart again and solder in resistors. Oh well, sucks that there's this difference
Ride That Thang!

Offline Winger

  • XR God
  • *****
  • Posts: 1663
  • Country: gb
  • Town: Birmingham
Re: OEM LED Turn Signals
« Reply #8 on: February 25, 2018, 02:23:35 PM »
Although my XT is from another era when I went LED with that just changed the indicator relay cost peanuts and took seconds to change.

Offline Mta1000XR

  • XR Member
  • **
  • Posts: 80
  • Country: us
  • Bike: 2018 S1000XR
  • Town: Connecticut
Re: OEM LED Turn Signals
« Reply #9 on: February 25, 2018, 03:01:14 PM »
There's no flasher relay in these newer ones correct? All ecu controlled.
Ride That Thang!

 


dysfunctional