Theme Select



Forum Default

Permanently

Author Topic: Cruise Control not working  (Read 3675 times)

0 Members and 1 Guest are viewing this topic.

Offline millview

  • XR Member
  • **
  • Topic Author
  • Posts: 59
  • Bike: 2020 S1000XR TE
  • Country: gb
Cruise Control not working
on: May 09, 2018, 05:59:29 PM
Just been out for a run today and noticed the cruise control has stopped working...any suggestions for checking before I contact the dealer?
BMW S1000XR TE

#1

Offline LAMBO281

  • Ex Member
  • XR Master
  • *
  • Posts: 518
  • Country: gb
Re: Cruise Control not working
Reply #1 on: May 09, 2018, 06:39:40 PM
After market levers fitted? Can catch the switch very easily

#2

Offline Winger

  • XR God
  • *****
  • Posts: 2956
  • Town: Birmingham
  • Country: gb
Re: Cruise Control not working
Reply #2 on: May 09, 2018, 06:48:37 PM
There by hangs a tale  :002:,i’ve No idea when mine stop working as I think i’ve tried it twice for novelties sake iin 2 years,,came to use it on the Peage the other week and nothing,haha I think after market lever,take it off and fit the original and still the same so at some time I will have to take a little more interest  :164:

#3

Offline millview

  • XR Member
  • **
  • Topic Author
  • Posts: 59
  • Bike: 2020 S1000XR TE
  • Country: gb
Re: Cruise Control not working
Reply #3 on: May 09, 2018, 07:21:43 PM
*Originally Posted by LAMBO281 [+]
After market levers fitted? Can catch the switch very easily

Same as Winger - I don't recall if it was working before I fitted new levers.  The switches look as they did when I fitted the levers though.  Is there a way of checking?
BMW S1000XR TE

#4

Offline LAMBO281

  • Ex Member
  • XR Master
  • *
  • Posts: 518
  • Country: gb
Re: Cruise Control not working
Reply #4 on: May 09, 2018, 07:57:07 PM
I know when cruise control is on I only need to tap the clutch lever about 1/2 inch (taking up the slack) before the sensor turns it off. Actually quite like it, easy tap with no jolting. I have the puigs fitted

#5

Offline Winger

  • XR God
  • *****
  • Posts: 2956
  • Town: Birmingham
  • Country: gb
Re: Cruise Control not working
Reply #5 on: May 09, 2018, 08:25:27 PM
*Originally Posted by millview [+]
Same as Winger - I don't recall if it was working before I fitted new levers.  The switches look as they did when I fitted the levers though.  Is there a way of checking?


Quite funny because when I  tried it the other week and it didn’t work I got into the realms of principle!!! because apart from once in 2 years cruise is about as much use to me as a chocolate teapot  :001: I changed back to a stock lever and it was the same and thought feck it I can’t be bothered.

Fast forward to your post and thought I really should get off my arse and sort it  :084: bend down and look under the lever there is a micro switch with two metal tabs the one at the bottom needs to be under the lever,pull the lever in and press it down with your other hand and let the lever go and hey presto so thanks for the boot up the arse  :001: and it does work i’ve Just ridden it.

#6

Offline bazzer

  • XR Master
  • ****
  • Posts: 978
  • Town: Waterlooville
  • Country: gb
Re: Cruise Control not working
Reply #6 on: May 10, 2018, 08:46:22 AM
You guys have slid the switch across to turn it on haven't you ?

You need to have it turned on and then press the engage button.

#7

Offline Winger

  • XR God
  • *****
  • Posts: 2956
  • Town: Birmingham
  • Country: gb
Re: Cruise Control not working
Reply #7 on: May 10, 2018, 11:26:04 AM
About a million times when I was bored on the Peage,when you take the lever off Be it aftermarket or stock it’s easy for the one metal strip to be at the back of the lever instead of underneath just pull the lever in and press the metal tab in with your thumb or finger.

#8

Offline barnsyuk

  • XR Member
  • **
  • Posts: 70
  • Bike: S1000XR
  • Town: UK South Coast
  • Country: gb
Re: Cruise Control not working
Reply #8 on: May 10, 2018, 11:31:10 AM
Yup it's all to do with the clutch lever, I had similar issues with stock levers, lubricated cables and joints and the lever returned to it's normal position and the cruise started working again. If you have aftermarket levers you need to make the microswitch behind the lever is working correctly and returning to the correct resting position.
Do I have a retirement plan, hell yes I plan to ride.

#9

Offline tor

  • XR Pro
  • ***
  • Posts: 122
  • Bike: 18 XR / 15 GSA
  • Town: Pee Dee of SC
  • Country: us
Re: Cruise Control not working
Reply #9 on: May 10, 2018, 11:33:34 AM
Just as an addition piece of information.

I had issues with my left switchgear on my 2015 GSA. The cruise would disconnect sometimes if the cruise lever was pulled back to "restore" previous cruise speed. I believe the switchgear on the XR is the same type gear used.

Quite a few others also had the same issue, primarily on GS and GSA. Not saying this is your issue, but just as an FYI. My switchgear was replaced under warranty.

 



dysfunctional