Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: '19 XR speedo display went haywire  (Read 912 times)

0 Members and 3 Guests are viewing this topic.

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #10 on: February 10, 2020, 09:56:26 PM »
 :047:
*Originally Posted by Asw63632004 [+]
My Speedo keeps going a bit funny. Every time I ride the bike the Speedo shows three numbers...the first one is always a '1'    :007:

Offline Winger

  • XR God
  • *****
  • Posts: 2309
  • Country: gb
  • Town: Birmingham
Re: '19 XR speedo display went haywire
« Reply #11 on: February 10, 2020, 10:11:21 PM »
Me too consequently I got a large fine and 6 points on my license in one go  :021:but hey ho it’s been a habit of a lifetime and i’m Certainly old enough too know better.

For you guys not in the UK 12 points and your walking.....
« Last Edit: February 10, 2020, 10:13:07 PM by Winger »

Online Asw63632004

  • XR Pro
  • ***
  • Posts: 197
  • Country: gb
  • Bike: XR1000 se Black
  • Town: Swindon UK
Re: '19 XR speedo display went haywire
« Reply #12 on: February 10, 2020, 10:21:58 PM »
I've got away with it so far . Just pure luck.
 Two years ago my buddy got a 60 Euro ( about £50) fine through the post . We were in Spain and doing 58kph in a 50 zone. Didn't even see the camera . He got the ticket posted to England. I got nothing  :745:
Andy

Offline Winger

  • XR God
  • *****
  • Posts: 2309
  • Country: gb
  • Town: Birmingham
Re: '19 XR speedo display went haywire
« Reply #13 on: February 11, 2020, 06:10:36 PM »
Even had a letter informing me that I had a 3 month ban from one Euro country but as the Dutch cop said ‘Vee know you Brits only fear points on your license’  :001:

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #14 on: February 12, 2020, 04:15:48 PM »
*Originally Posted by Asw63632004 [+]
My Speedo keeps going a bit funny. Every time I ride the bike the Speedo shows three numbers...the first one is always a '1'    :007:

I was at a stop light next to a motor officer a few months ago.  As we were sitting there, he asked me, "how fast does your bike go?"  I answered, "it goes the speed limit, sir."  He replied, "best answer ever" and sped off.   :008:

Online Asw63632004

  • XR Pro
  • ***
  • Posts: 197
  • Country: gb
  • Bike: XR1000 se Black
  • Town: Swindon UK
Re: '19 XR speedo display went haywire
« Reply #15 on: February 12, 2020, 06:06:39 PM »
 :152:. Good answer. I'll remember that one  :001:
Andy

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #16 on: February 14, 2020, 04:24:15 PM »
*Originally Posted by shinobi13 [+]
I had a new problem with the XR on a ride yesterday. My dash went complete haywire... all of the individual displays (service light, ABS light, ASC light, speed, gear indicator, miles, heated grips, etc.) all flashed intermittently. Turn signals stopped working as well. This went on for a while and then my display went completely blank and the displayed “NO CAN”.

The engine still functioned with no power loss and didn’t go into any limp mode.

WTF??? If anyone has any ideas what happened, I’d love to know. I’m happy it’s still under warranty and will get in to the dealership sometime this week...

Lee

I dropped the XR to the dealership yesterday afternoon. Hopefully, I'll know within the next few days why my dash turned into a pinball machine. On a good note, I have a 2020 R1250 RS as a loaner until i get the XR back. The one I rode previously (from the BMW demo fleet) didn't handle nearly as nice as this one. If something catastrophic happens to the XR, this RS may be the next one in the stable...  :001:

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #17 on: February 18, 2020, 03:41:06 PM »
Well, the BMW service advisors told me on Saturday not to expect my XR back anytime soon. They can't seem to find what's causing the issue and have referred my case to the engineers at BMW Motorrad North America...  :232:

As much as I like the RS as a loaner, I really miss my XR.

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #18 on: February 20, 2020, 03:44:36 PM »
Here's the latest update:

After checking all wiring, connections, battery, switches, etc., and checking with BMW Motorrad North America engineers, they are going to replace the dash. The dash worked fine on the bench when troubleshooting, but they are at a loss to diagnose why and what truly happened with the XR.  :084: The new dash should be in today and I will be back on the XR by Saturday, hopefully...

BTW, I have done business with this dealership for many years and I trust their techs... they're a good lot...

Offline shinobi13

  • XR Member
  • **
  • Posts: 28
  • Country: us
  • Bike: 2019 BMW S1000XR
  • Town: Rio Rancho, NM
Re: '19 XR speedo display went haywire
« Reply #19 on: February 21, 2020, 07:03:17 PM »
Today's update:
The new dash displayed the same behaviors.  A case has been opened with BMW North America.  The engineers are baffled why the instruments behave the way they do without the bike going into limp mode or affecting how it runs.

 



dysfunctional