Author Problem with charging!!  (Read 1233 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Anestis93   gr

    • XR Junior  ‐    2
    • *
    • Topic Author

    Offline Anestis93

    • XR Junior
    • *
    • Topic Author
    • Posts: 2
    • Bike: S1000XR
    • Town: Thessaloniki
    • Country: gr
    Problem with charging!!
    on: November 29, 2021, 01:16:44 pm
    November 29, 2021, 01:16:44 pm
    Hello, I have a problem in trying to find a solution my self before taking to the dealer!
    My problem is that when the engine runs I don't see more than 12.5v, so I thought that maybe generator is dead so I tested it and it makes 17v after that I tested voltage regulator and on the outside makes 15v so it's OK, I checked the reles and the electrical fuses and it’s also OK, I changed a battery and still have the same problem!
    Any ideas what this might be?

    Thank you for your time!

  • Offline JerryG   us

    • XR Pro  ‐    241
    • ***
      #1

    Offline JerryG

    • XR Pro
    • ***
    • Posts: 241
    • Bike: 2021 S1000XR
    • Town: Hendersonville
    • Country: us
    Re: Problem with charging!!
    Reply #1 on: November 30, 2021, 05:05:26 pm
    November 30, 2021, 05:05:26 pm
    My '17 RR is currently in the shop for not charging and my dealer determined that the stator wasn't putting out enough. Because of your post, I called the service manager and asked what had actually been tested and described what you posted, he said they had tested my stator along with a number of other specs because volts don't tell the whole story, that each of the connections has it's own spec and you'd have to check them all to determine what was happening for you. Sorry I can't help more.

  • Offline JerryG   us

    • XR Pro  ‐    241
    • ***
      #2

    Offline JerryG

    • XR Pro
    • ***
    • Posts: 241
    • Bike: 2021 S1000XR
    • Town: Hendersonville
    • Country: us
    Re: Problem with charging!!
    Reply #2 on: November 30, 2021, 05:08:07 pm
    November 30, 2021, 05:08:07 pm
    One other piece of info you might find alarming: The price for basically replacing my RR's whole charging system is $1600 for parts plus $500 for labor.  :005:

  • Offline wessie   gb

    • XR Master  ‐    622
    • ****
      #3

    Offline wessie

    • XR Master
    • ****
    • Posts: 622
    • Bike: 2016 XR SE Sport
    • Town: Cheltenham
    • Country: gb
    Re: Problem with charging!!
    Reply #3 on: November 30, 2021, 05:19:51 pm
    November 30, 2021, 05:19:51 pm
    have you checked the earth connection from the battery to the frame and/or engine plus any other earth straps.

    No, I have no idea where they are on the XR but many vehicle electrical faults can be traced to poor earthing. It only take a little bit of corrosion to add resistance to the circuit, leading to the voltage drop you describe.

  • Offline Crosshairs   us

    • XR Pro  ‐    241
    • ***
      #4

    Offline Crosshairs

    • XR Pro
    • ***
    • Posts: 241
    • Town: Oceanport
    • Country: us
    Re: Problem with charging!!
    Reply #4 on: December 01, 2021, 12:19:13 am
    December 01, 2021, 12:19:13 am
    *Originally Posted by Anestis93 [+]
    Hello, I have a problem in trying to find a solution my self before taking to the dealer!
    My problem is that when the engine runs I don't see more than 12.5v, so I thought that maybe generator is dead so I tested it and it makes 17v after that I tested voltage regulator and on the outside makes 15v so it's OK, I checked the reles and the electrical fuses and it’s also OK, I changed a battery and still have the same problem!
    Any ideas what this might be?

    Thank you for your time!

    At what RPM are you checking the voltage output?
    Proud member of the 10/40 club

  • Offline Anestis93   gr

    • XR Junior  ‐    2
    • *
    • Topic Author
    • #5

    Offline Anestis93

    • XR Junior
    • *
    • Topic Author
    • Posts: 2
    • Bike: S1000XR
    • Town: Thessaloniki
    • Country: gr
    Re: Problem with charging!!
    Reply #5 on: December 01, 2021, 07:07:47 am
    December 01, 2021, 07:07:47 am
    I checked any earth connection and it seems fine
    I had a problem with the stator and I had it rebuild because of the prices you said so it might be this..
    I will take it to the dealer and see what they will tell!